1
0
-1

when I try to debug an application (uniface.exe) I get 

0008 - Failed to activate Start-up shell screen.

    CommentAdd your comment...

    3 answers

    1.  
      1
      0
      -1

      Recent installations of Uniface have this issue IME. The 'solution' is to copy the udbg.asn from

       {Uniface Install Dir}\uniface\adm

      to 

      {Uniface Install Dir}\common\adm

      I can't find anything in the ini files on my system which would seem to affect this. Daniel may be able to suggest something. 

      Regards, 

      Iain

      1. Alex Meyers

        thx, this works

        but I do not see what the difference with putting usys:udbg.uar in  [RESOURCES] ?

      2. Iain Sharp

        The debugger is a separate executable started with it's own asn file (the udbg.asn). I can't find anywhere where you can change the asn file name used to start the debugger process. 

        The documentation references this assignment file, 

        https://u.uniface.info/docs/0907/uniface/configuration/configurationFiles.htm?Highlight=udbg.asn

        However, as I say, it seems that recent installs require the asn file copying to the common\adm folder in uniface to get it to actually work. 

      CommentAdd your comment...
    2.  
      1
      0
      -1

      Hi Gianni,

      Uniface 10.3

      the app is started as "uniface.exe /asn=myasn myapp.aps"

      the asn has the database refs and my own uar in [RESOURCES]

      I tried with following line which I found in installdir\uniface\udbg.asn (usys:udbg.uar)  added to [RESOURCES] but to no avail

      if I do not start with /dbg or a debug statement in specific trigger the app runs, but when I start with /dbg switch or hit a debug proc statement the 0008 error pops up

      Alex


      1. Daniel Iseli

        Hi Alex,

        The Debugger needs the udbg.asn that is located in \uniface\adm. Normally Uniface is started with the /adm switch that should point to {Uniface Install Dir}\uniface\adm.

        You could create a udbg.asn in \common\adm with the following content:

        #file usysuniface:adm\udbg.asn

        This should solve the problem (regardless if and how /adm is set).

        I hope this helps.

        Daniel

      2. Iain Sharp

        If you use /adm then all your asn files have to be in the mentioned folder, so application based asn files have to be in the uniface install folder, or the uniface asn (ini) files need to be copied into the application folder. 

        I think the debugger default adm folder has changed with the later releases of Uniface, to common from uniface

      3. Daniel Iseli

        No sure where you've got this from, but that's not really the case. When /adm is not specified then Unfiace will default to \common\adm. That's about all. It's not necessary to have all the application based asn files in uniface\adm. You can specify a different location by using /asn.

        And the Debugger is inheriting the adm-folder from the application it started. This behavior was not changed.

        If you check the "Client Debug" shortcut of your Uniface installation then you'll see that /adm is used (and it's pointing to \unfiace\adm). This, however, is only used when starting the Debugger stand-alone (instead from the application with /dbg or by executing the debug statement).

      4. Daniel Iseli

        Okay, forgot one little thing: the Debugger also needs the usys.ini from \uniface\adm. The usys.ini in \common\adm does not include all the settings for the Debugger or Development Environment.

      5. Iain Sharp

        If you use /adm, in your startup, then you have to include files like usys.ini in the folder mentioned, it no longer uses the uniface folder. Which is what I was trying to say. 


      CommentAdd your comment...
    3.  
      1
      0
      -1

      Hi Alex,

      it seems you have an unstable configuration for your Uniface application.

      When debugger must be started, Uniface is looking into the runtime environment and find the debugger configuration; something is going wrong there...

      Which version of Uniface are you running?

      Regards,
      Gianni

        CommentAdd your comment...