1
0
-1

Dear fellas,

This is my first week get in touch with Uniface9. I'm trying to go through the exercise materials in u9FoundationExercise.

I don't know for some reason, I followed Excercise 16 Part 1 - Sequence, I can't retrieve any data into my form.

Can anybody help me?

Cheers 

    CommentAdd your comment...

    5 answers

    1.  
      1
      0
      -1

      The question what is the name of the entity? Use for example retrieve/e "yourentname". Is that entity painted? if yes, is that entity a database entity? if yes, has the read trigger a read statement? if yes, is there a database connection...that easy to test $procError, $procErrorContext, $dataError, $dataErrorContext contains values when it go's wrong....with other words, does the used retrieve profile deliver hits? 

      retrieve/e "bla"

      if ($procError < 0)

      message/error "%%$procErrorContext%%%, %%$dataErrorContext%%%"

      endif

      if ($status = -2)

      message/hint "no hits found"

      endif

      Cheers

      Dino Seelig


        

        CommentAdd your comment...
      1.  
        1
        0
        -1

        Shooting from the hip: A classic mistake is having no read statement in the Read trigger...

          CommentAdd your comment...
        1.  
          1
          0
          -1

          Hi Harry,


          Put a debug statement line before the retrieve, compile, test and step through the code. See what $status and $procerror tell you. I realise you are new and may not have used the debugger yet, however it is relatively straightforward to use.


          Regards,


          Jason, 

            CommentAdd your comment...
          1.  
            1
            0
            -1

            Does the message frame (GOLD-M) have any messages? 

              CommentAdd your comment...
            1.  
              1
              0
              -1

              Here is the material

                CommentAdd your comment...