1
0
-1

I'm following up on this via this link; https://oraclefact.wordpress.com/2018/04/05/client-server-interoperability-support-matrix-for-different-oracle-versions-doc-id-207303-1/

It would appear a 12.1 client can connect seamlessly to 12.1 and 12.2 versions of the database.

Thus, I presume there's still life in the U7.1 driver?

However, I also remember a post (from 2017 I think) outlining the NEED to use U7.2 against a 12.2 database - but I cannot seem to find that post.  I'm pursuing this because we will end up going to a 12.2 database later this year and need to plan the rollout of client software as well as potentially having to upgrade Uniface...

Knut

    CommentAdd your comment...

    1 answer

    1.  
      2
      1
      0

      Hi Knut,

      The Uniface Oracle drivers only communicate with the Oracle client. The drivers are built against libraries of a specific version of the Oracle client software, so those two need to be in sync. The Oracle server version behind the client is not relevant for the version of the Uniface Oracle driver. So you are correct. As Oracle supports the combination of a 12.1client with a 12.2 database server, a combination of Uniface Oracle driver U7.1, Oracle client 12.1 and Oracle server 12.2 will work. Similar combinations of have been used before and I do not remember they ever gave problems.

      Best regards,

      Jan Cees

      CommentAdd your comment...