Page tree

Uniface Anywhere Client is not optimized for your MAC (07-Nov-2019)


32-bit app compatibility with macOS High Sierra 10.13.4


Starting with macOS High Sierra 10.13.4, apps that have not been updated to use 64-bit processes produce a one-time alert when opened. 

The current released version 5.0.2 of the Uniface Anywhere Client for macOS X is producing the following message when started on macOS High Sierra 10.13.4:
Uniface Anywhere Client” is not optimized for your Mac.

This message gives users advance notice that they are running 32-bit software, which will not be compatible with macOS in the future.

The Uniface Anywhere Client can still be used on this version without any adverse effects on your data or your computer.


Uniface will release a fully 64-bit macOS X client with Uniface Anywhere version 6.0.


More information on this transition by Apple can be found at https://support.apple.com/en-us/HT208436


Uniface Anywhere versions 5 Mac Client not compatible with MAC OS 10.15 Catalina.

Uniface recommends to wait with updating the Mac OS to Catalina until version 6 of Uniface Anywhere has been released.

But for those who have already installed the Catalina version, you can download the Uniface Anywhere version 6 Mac Client from here: ua6-client.mac.dmg

Please Note:

  • You won't be able to run the 6.0 client from Safari until you upgrade the hosts to version 6.0. This is because the 6.0 client relies on the host's support for WebSockets to launch the client from a browser.
  • Some functionality may not be available until the host is updated to version 6